Scheduled for March 19, 2025 at 12:30 PM – 2:00 PM
Affects
Mobile App
Under maintenance from 12:30 PM to 2:00 PM
Updates
Completed
March 19, 2025 at 2:00 PM
Completed
March 19, 2025 at 2:00 PM
Maintenance has completed successfully
In progress
March 19, 2025 at 12:30 PM
In progress
March 19, 2025 at 12:30 PM
Maintenance is now in progress
Planned
March 19, 2025 at 12:30 PM
Planned
March 19, 2025 at 12:30 PM
As part of our continuous upgrade & systems improvement programme, we will be performing routine system maintenance on our infrastructure between 14h30 and 16h00. We don't expect there to be any disruptions.